网站主页   操作系统    网络工程    服务器    网页制作    数据库    程序开发    网络安全    办公软件   
讲座日期: 本周六下午1点30分 抢座
讲座地点: 北大青鸟马甸校区
主讲老师: 王老师 金牌讲师
讲座主题: 网络安全
讲座内容: 检测、防御、黑客信息,如何过滤不安全的网站,如何防御黑客的进攻。
订座电话: 010-82011432/33
  您当前位置:主页 > 网络学院 > 网络安全 > 防火墙 >

基础使用cisco pix 防火墙




  •   1.interface command

      在配置用户接口的时候我们经常听到关于接口的专有名词

      hardware_id指ethernet 0,e1,e2

      interface_name指outside,inside,dmz

      hardware_speed,通产设置为自动,但是cisco推荐我们手动配置速度.关于速度和你选择的网络传输介质有关.

      no shutdown在router上用户激活这个端口,在pix中,没有no shutdown命令,只有使用到shutdown这个参数,主要用于管理关闭接口.

      interface hardware_id hardware_speed [shutdown]

      interface e0 auto

      interface e1 auto

      interface e2 auto

      2.nameif command

      nameif 主要用于命令一个接口,并且给它分配一个从1到99的安全值,因为外部接口和内部接口都是默认的,分别是0和100,同时默认情况下e0是外部接口,e1是指内部接口.

      nameif hardware_id if_name security_level

      nameif e0 outside 0

      nameif e1 inside 100

      nameif e2 dmz 50

      使用show nameif来查看配置情况

      关于security_level值得区别,请都看看我前面写的.从高安全段的流量到低安全段的流量怎么走,放过又怎么走,需要什么条件才能流进流出.

      3.ip address command

      cisco pix接口的ip 地址可以从两个地方来获得,分别是 manual 和dhcp

      ip address用于手动配置一个接口上的ip address,通过将一个逻辑地址添加到一个硬件ID上.

      ip address if_name ip_address [netmask]

      ip address inside 192.168.6.0 255.255.255.0

      Remove the currently configured ip address pix(config)#clear ip address (全部清除ip address)

      pix(config)#no ip address inside 192.168.6.0 255.255.255.0(清除这个接口的ip address)

      4.Nat command

      用于一组ip 地址转换成另外一组ip 地址,昨天我看到6.2版本支持nat outside ip address,不知道这个究竟在什么环境才用到,呵呵

      在用nat命令的时候,有个特别的注意点:nat 0有特殊含义,其次nat 总是和global一起使用.

      nat (if_name) nat_id local_ip [netmas]

      nat (inside) 1 192.168.6.0 255.255.255.0

      5.Global command

      global命令用于定义用nat命令转换成的地址或者地址范围,注意global命令中的nat_id需要和你配置的nat命令中的nat_id相同.

      global (if_name) nat_id global_ipglobal_ip-global_ip [netmask]

        


    上一篇:理解Cisco PIX 防火墙的转换和连接  
    下一篇:pix535实际配置
    相关信息:

    ·Linux防火墙数据包捕获模块 ·巧妙利用Linux系统IP伪装防黑
    ·Linux防火墙程序设计 ·一款Linux的防火墙实例
    ·实现Linux网络防火墙 ·中小企业自建Linux防火墙
    ·在Linux代理服务器上设置防火墙 ·Linux免费防火墙试用手记
    ·使用iptables建置Linux 防火墙(2) ·使用iptables建置Linux 防火墙(3)

    Copyright © 2002-2015 版权所有
    学校地址:北京市海淀区西三旗建材城中路29号北大青鸟
    招生热线:010-82011433/32 京公网安备110102004704  京ICP备05043413号 京公网安备110102004704