网站主页   操作系统    网络工程    服务器    网页制作    数据库    程序开发    网络安全    办公软件   
讲座日期: 本周六下午1点30分 抢座
讲座地点: 北大青鸟马甸校区
主讲老师: 王老师 金牌讲师
讲座主题: 网络安全
讲座内容: 检测、防御、黑客信息,如何过滤不安全的网站,如何防御黑客的进攻。
订座电话: 010-82011432/33
  您当前位置:主页 > 网络学院 > 网络工程 > VLAN技术 >

菜鸟学划分VLAN




  ,被称为逻辑范围广播域,或是。主要通过减少广播降低网络性能得影响。在网络环境中建立,对网络有以下特点

  一、灵活性:的部署不地理或物理位置的限制,添加或删除成员不需要调整物理线缆

  二、安全性:如果没有路由设备(路由器和三层交换机)内可以通讯,间不可以

  三、划分网段:一个等于一个广播域等于一个逻辑网段

  在网络环境中如果是跨多个交换机的,需要在这些交换机中找出一台做为服务器,用于通告整个网络环境的信息。而通过通告信息的协议被称为VTP协议

  VTP:主干协议,用于通告信息。VTP有一下三种模式:服务器模式、客户端模式、透明模式。在此我们只介绍前两个,因为第三个很少用

  ·服务器模式(server):

  ① 用于建立、删除、修改

  ② 发送和转发信息

  ③ 实现信息的同步

  ④ 存储在自己的NVRAM内

  ·客户机模式(client):

  ① 不能建立、修改、删除

  ② 发送转发信息

  ③ 信息同步

  ④ 信息存储在服务器上

  下面我们开始看一下的具体配置:

  试验环境如下

  

  注:本次试验交换机均为二层设备

  试验目的:PC1与PC3可以相互通讯

  PC2与PC4可以相互通讯

  PC1-192.168.10.1

  PC2-192.168.10.2

  PC3-192.168.10.3

  PC4-192.168.10.4

  配置server交换机

  Server# database

  进入数据库模式

  Server()#vtp domain abc

  创建一个域名,名字为abc。多交换机换分需要在服务器上建立一个域,以便客户交换机加入到域中(注:不是windows中的AD)

  Server()#vtp server

  指定本交换机是服务器还是客户机,再此我们指定为服务器模式

  Server()# 2 name 2

  建立,命令为Server()# 号 name 名

  我们建立的2号,为了方便记忆,的名字也为2,注意:1号不可用,因为一号用于管理交换机,在最后会有专门的讲述

   2 added:

  Name:2

  Server()#apply 确认2号,如果确认建立,输入apply。如错误,输入abor

  Server()# 3 name 3

   3 added:

  Name:3

  Server()#apply

  建立三号,号为3,名称也为3

  Server(config)#int fa0/1 进入fa0/1端口

  Server(config-if)#switchport mode access 声明此端口为访问端口

  Server(config-if)#switchport access 2 把此端口添加到2号中

  Server(config-if)#int fa0/2 进入fa0/2端口

  Server(config-if)#switchport mode access 声明把此端口设置为访问端口

  Server(config-if)#switchport access 3 把此端口添加到3号中

  下面我们开始配置干线,干线用于承载多条信息链路,在中继端口上配置

  Server(config-if)#int fa0/12 进入fa0/12端口

  Server(config-if)#switchport mode trunk 声明此链路为干线链路

  Server(config-if)#switchport trunk encapsulation dot1q 封装干线信息

  在完成server交换机配置后我们可以在#模式下使用show 命令查看一下信息,下图显示了我们在server交换机上配置了两个

  

  我们还可以使用show VTP status命令查看一下VTP的信息,下图显示了的模式为服务器模式,名字为ABC

  

clip_image004

  Server#copy running-config startup-config 保存配置,使配置生效

  配置client交换机

  Client# database 进入数据库模式

  Client()#vtp domain abc 声明要加入的域得名字

  Client()#vtp client 声明自己为客户端模式

  Client(config)#interface fa0/12 进入中继端口,开始配置干线和干线协议

  Client(config-if)#switchport mode trunk 声明为干线

  Client(config-if)#switchport trunk encapsulation dot1q 封装干线信息

  客户端加入到域中不需要在新建立,当客户端加入到服务器的时候自己的信息中就有了整个的,如下图,我们使用show 可以查看到信息有已经有我们刚才在server交换机上创建的2号和3号

  

  下面我们只需要把端口添加到域中的即可

  Client(config)#interface fa0/1 进入fa0/1端口

  Client(config-if)#switchport mode access 设置此端口为访问端口

  Client(config-if)#switchport access 2 把此端添加到2号

  Client(config-if)#interface fa0/2 进入fa0/2端口

  Client(config-if)#switchport mode access 设置为访问端口

  Client(config-if)#switchport access 3 把此端口添加到3号

  下面我们可以在客户机交换机上使用show 查看到2号有了fa0/1端口,三号有了fa0/2端口

  

clip_image008

  下面我们使用show vtp status 查看一下VTP域的模式,我们可以看到为客户端模式,名字为ABC

  

  Client#copy running-config startup-config 保存配置

  本次试验结果:

  PC1和PC3可以相互通讯

  PC2和PC4可以相互通讯

  下图是在PC1上ping其它计算机的结果

  

  下图是在PC3上得到的试验结果

  


上一篇:VLAN的Hybrid和Trunk端口有何区别?  
下一篇:Vlan的两种特殊情况
相关信息:

·模拟C3640交换机实现VLAN通信 ·与应用IP子网相比,应用VLAN有何益处?
·解决VLAN疑难问题:如何监控802.1q标记流量 ·如何应用VLAN和NAT提供静态IP地址?
·常见VLAN攻击手段及如何避免 ·Vlan的两种特殊情况
·VLAN的Hybrid和Trunk端口有何区别? ·虚拟网络VLAN的配置管理与维护
·VLAN实验——三层交换原理 ·解析光纤到户接入技术FTTH应用策略

Copyright © 2002-2015 版权所有
学校地址:北京市海淀区西三旗建材城中路29号北大青鸟
招生热线:010-82011433/32 京公网安备110102004704  京ICP备05043413号 京公网安备110102004704