网站主页   操作系统    网络工程    服务器    网页制作    数据库    程序开发    网络安全    办公软件   
讲座日期: 本周六下午1点30分 抢座
讲座地点: 北大青鸟马甸校区
主讲老师: 王老师 金牌讲师
讲座主题: 网络安全
讲座内容: 检测、防御、黑客信息,如何过滤不安全的网站,如何防御黑客的进攻。
订座电话: 010-82011432/33
  您当前位置:主页 > 网络学院 > 网络工程 > VLAN技术 >

cisco交换机配置vlan的资料




  * 配置思路 (access 、Trunk)

  (1)创建

  在基于IOS的交换机上配置静态:

  switch# database

  switch()# -num name -name

  switch()# exit

  switch# configure teriminal

  switch(config)# interface interface module/number

  switch(config-if)# switchport mode access // 设置端口模式为access模式

  switch(config-if)# switchport access -num // 设置端口所属的

  switch(config-if)# end

  核验配置:show

  (2)配置干道链路

  干道是在两台catalyst交换机端口或catalyst交换机与路由器间的一条点对点链路。 干道链路可以承载多个。

  在基于IOS的交换机上配置干道链路

  switch(config)# interface interface mod/port

  switch(config-if)# switchport mode trunk // 设置端口模式为trunk模式

  switch(config-if)# switchport trunk encapsulation // 设置trunk所封装的帧

  switch(config-if)# switchport trunk allowed remove -list // 允许那些通过干路

  ( 附:switchport trunk allowed {add | all | except | remove} -list )

  * no switchport

  no switchport // 把物理端口变成三层口,即把三层口当成路由器上的口,当将一个端口配置成三层端口之后,就可以在此端口上分配IP地址了,当然还是可以连接PC机的,。 路由口:路由口是指某一物理端口在端口配置状态下用no switchport命令生成的端口,所有的三层都需要IP地址以实现路由交换。

  配置举例如下:

  Switch# configure terminal

  Switch(config)# interface gigabitethernet0/2

  Switch(config-if)# no switchport

  Switch(config-if)# ip address 192.20.135.21 255.255.255.0

  Switch(config-if)# no shutdown

  Switch(config-if)# end

  附:show interfaces [interface-id] switchport // 显示二层端口的状态,可以用来决定此口是否为二层或三层口。 Eg:Switch# show interfaces fastethernet 0/1 switchport

  * 三层交换机上的设置

  (1)方法一:一般常规配置

  Switch# configure terminal

  Switch(config)# 20

  Switch(config-)# name test20

  Switch(config-)#ip address 1.1.1.1 255.255.255.0

  Switch(config-)# end

  方法二:也可以在enable状态下,进行配置:

  Switch# database // 进入配置状态

  Switch()# 20 name test20 // 加入号及名

  Switch()# exit 更新数据库并退出

  (2)将端口分配给某个

  Switch# configure terminal

  Switch(config)# interface fastethernet0/1

  Switch(config-if)# switchport mode access // 定义二层口的工作模式为接入模式

  Switch(config-if)# switchport access 2 // 把端口分配给某一

  Switch(config-if)# end

  Switch#

  (3)配置 Trunks

  Switch# configure terminal

  Switch(config)# interface fastethernet0/4

  Switch(config-if)# switchport mode trunk

  Switch(config-if)# switchport trunk encapsulation dot1q

  Switch(config-if)# end

  附:switchport trunk encapsulation {isl | dot1q | negotiate} // 配置trunk封装ISL 或 802.1Q 或自动协商

  switchport mode {dynamic {auto | desirable} | trunk} (一般不用它),配置二层trunk模式。(dynamic auto—自动协商是否成为trunk;dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 或自动模式;trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk)

  (4)定义trunk允许的

  Switch(config)# interface fastethernet0/1

  Switch(config-if)# switchport trunk allowed remove 2 // 配置trunk允许的

  Switch(config-if)# end

  附:switchport trunk allowed {add | all | except | remove} -list

  (5)配置Native (802.1q)

  switch(config-if)# switchport trunk native -num // 封装802.1q的trunk端口可以接受带有标签和不带标签的数据流,交换机向native 传送不带标签的数据流,缺省情况下native 是 1

  使用no switchport trunk native 端口配置命令回到缺省的状态

  (6)配置一组端口

  4006# configure terminal

  4006(config)# interface range fastethernet2/1 – 5

  4006(config-if-range)# no shutdown

  // 注意:端口号之间需要加入空格,如:interface range fastethernet 2/1 – 5 是有效的,而interface range fastethernet 2/1-5 是无效的.

  以下的例子显示使用逗号来配置不同类型端口的组:

  4006# configure terminal

  4006(config)# interface range fastethernet2/1 – 3, gigabitethernet3/1 - 2

  4006(config-if-range)# no shutdown

  (7)其它常用命令

  duplex {auto | full | half} // 设置全双工或半双工.

  speed {10 | 100 | 1000 | auto | nonegotiate} 设置端口速率 // 注:1000 只工作在千兆口. GBIC模块只工作在1000 Mbps下. nonegotiate 只能在这些GBIC上用 1000BASE-SX, -LX, and -ZX GBIC.

  copy running-config startup-config // 保存设置

  (8)配置EtherChannel

  以太通道捆绑几个以太端口为一个独立的逻辑链路。如4006交换机,你可以捆绑在4006任何模块上最多8个兼容的具有相同速率的端口。每个以太通道具有一个port-channel端口号。要捆绑一个以太通道时,会产生一个逻辑port-channel端口,逻辑端口下的配置可影响与之捆绑的物理端口,但物理端口下的配置不能影响逻辑端口的配置。

  1) 三层以太通道(逻辑port-channe)的配置

  Switch# configure terminal

  Switch(config)# interface port-channel 1 // 创建一个逻辑端口

  Switch(config-if)# ip address 172.32.52.10 255.255.255.0

  Switch(config-if)# end

  2) 三层物理端口配置

  Switch# configure terminal

  Switch(config)# interface range fastethernet 5/4 – 5 (注意: 空格是必需的)

  Switch(config-if)# no switchport // 改变该端口为三层接口

  Switch(config-if)# no ip address // 确认接口没有配置IP地址

  Switch(config-if)# channel-group 1 mode desirable

  Switch(config-if)# end

  附: Switch(config-if)# channel-group port_channel_number mode {auto | desirable | on} // 将该物理端口加入一个以太通道中,并确定PagP模式。

  3) 二层以太通道配置

  Switch# configure terminal

  Switch(config)# interface range fastethernet 5/6 - 7 (注意: 空格是必需的)

  Switch(config-if-range)# channel-group 2 mode desirable

  Switch(config-if-range)# end

  Switch# show running-config interface port-channel 2

  Building configuration...

  Current configuration:

  !

  interface Port-channel2

  switchport access 10

  switchport mode access

  end

  Switch#

  * 如何作端口聚合

  如果要配置二台6509之间的Trunk联接,首先将二6509用千兆光纤相联好,然后分别配置二相联端口的trunk,可以是只用一双光纤,或用二对光纤做port channel,配置如下:

  一双光纤相联时,分别在二台65上进行以下的配置:

  interface GigabitEthernet1/1

  no ip address

  switchport

  switchport trunk encapsulation dot1q

  switchport trunk native 1

  二对光纤相联时,必须要做port channel,分别在二台65上进行以下的配置:

  interface port-channe1

  no ip address

  switchport

  switchport trunk encapsulation dot1q

  switchport trunk native 1

  !

  interface GigabitEthernet1/1

  no ip address

  duplex full

  speed 1000

  switchport mode trunk

  switchport trunk encapsulation dot1q

  switchport trunk native 1

  channel-group 1 mode on

  !

  interface GigabitEthernet1/2

  no ip address

  duplex full

  speed 1000

  switchport mode trunk

  switchport trunk encapsulation dot1q

  switchport trunk native 1

  channel-group 1 mode on

  * VTP裁剪

  (1)在基于IOS的交换机上配置VTP 模式:

  switch# database

  switch()# vtp domain domain-name

  switch()# vtp

  switch()# vtp password password

  在基于CLI的交换机上配置VTP 模式:

  switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

  (2)在基于IOS的交换机上配置VTP版本:

  switch# database

  switch()# vtp v2-mode

  在基于CLI的交换机上配置VTP版本:

  switch(enable) set vtp v2 enable

  (3)在基于IOS的交换机上启动VTP剪裁:

  switch# database

  switch()# vtp pruning

  在基于CLI 的交换机上启动VTP剪裁:

  switch(enable) set vtp pruning enable


上一篇:VLAN 配置基础及实例探讨  
下一篇:Cisco 3550 vlan的划分
相关信息:

·模拟C3640交换机实现VLAN通信 ·与应用IP子网相比,应用VLAN有何益处?
·解决VLAN疑难问题:如何监控802.1q标记流量 ·如何应用VLAN和NAT提供静态IP地址?
·常见VLAN攻击手段及如何避免 ·Vlan的两种特殊情况
·菜鸟学划分VLAN ·VLAN的Hybrid和Trunk端口有何区别?
·虚拟网络VLAN的配置管理与维护 ·VLAN实验——三层交换原理

Copyright © 2004-2015 北大青鸟马甸校区 北京北方华腾技术培训中心 版权所有
学校地址:北三环中路马甸桥东北角商房大厦(国美电器)626
招生热线:010-82011433/32 京公网安备110102004704  京ICP备05043413号 京公网安备110102004704